audio - No sound from headphones under ubuntu 13.10

16
2014-04
  • Eugene B

    I have a fresh ubuntu on iMac. I have managed to set up the sound from the native speakers, however, there is still no sound from the headphones. I have disabled automute in alsamixer, but this didn't help. Does anyone know what to do in this case?

  • Answers
  • Eugene B

    The solution was found by adding a row of options snd-hda-intel model=imac27_122 to /etc/modprobe.d/alsa-base.conf as explained here.

    enter image description here


  • Related Question

    audio - No sound from internal speakers on a Macbook?
  • Kayle

    I'm afraid I may have irreversibly harmed my internal speakers, or sound system in general.

    Yesterday, I was trying to find a way to hook up my electric guitar to the computer. I, logically, thought that going through my amp and running the amp to the macbook line-in was the best course of action.

    What came through my external speakers was just muffle-ly cracked noise that were very unstable sounding. After failing to get a decent sound, I found that my sound in general sounded really weird.

    Now I get sound through the headphone jack, but it has odd sound artifacts around any sounds that are played, and when removed the internal speakers do not make any sound at all (but APPEAR available on the system and I can still adjust the volume). Here's what I've tried so far:

    • Tickling the sensor in the phone jack, managed to turn the red light on and off several times. No effect.

    • Hardware reset (by holding the power button for a while... could not hear the system "dings" though, due to the absence of sound)

    • Logging in to Linux partition. Same problem there.

    • Changing sound inputs a couple times and starting up and shutting down garageband with new and old projects.

    Any other ideas? Or have I permanently harmed my sound system?

    EDIT: Wanted to add that this macbook is past warranty and there's no apple stores nearby anyway. So I won't be taking it to a retailer.


  • Related Answers
  • y3sh

    Given that you changed OS's -- to the linux partition -- and still had the same problem, it sounds like a hardware problem.

    If you did damage the hardware, don't worry -- you're not completely screwed. This may be the best excuse to upgrade your audio hardware with an external sound card.

    Creative has some great ones that I have used along with Adobe Audition. However most of them are PC only... but in their professional brand (E-MU), they have some great ones for mac.

    Creative's professional brand, E-MU is what I currently use. Details here:

    Amazon link here: